TACTIC Team equivalent for Linux?

4 posts / 0 new
Last post
abdelrahman
TACTIC Team equivalent for Linux?

Hi,

I am running Linux Mint 18.1 and I would love to use TACTIC for my own personal work. Now, I am mostly working on my own, so I don't need anything complicated. When I tried TACTIC Team on Windows, I found it very simple and it fits my needs. The Linux VMWare Image does the job for me, but the one thing that annoys me about it is the fact that my files are not installed locally. Of course I can connect to the virtual machine via the network, but I prefer to have everything on the local drives or on a proper server storage rather than on the virtual machine itself.

Now, I have tried installing TACTIC Enterprise since, as far as I know, it is the other option I have on Linux, but I still haven't managed to get it to work for me. I can keep going troubleshooting until everthing works, but I just think that it is not worth doing it, since the Enterprise version is just too much for what I need.

This is why I wanted to know if there is anyway to have some sort of installation that is as simple as the TACTIC Team on Windows, but still runs and operates on my local Linux computer instead of a virtual machine.

remko

There isn't really an option like that for Linux for 3 reasons.  1) The relatively small number of user using Linux as a personal machine and 2) the relative ease in which to install TACTIC on Linux and 3) the amount of work it takes to package up team for an OS.  I know that doesn't help much in your situation, but these are the reasons.

What I can do is give you the steps I used to prepare my Fedora 25 VM.  It should be relatively translateable to any Linux.  Hopefully, this will help you and any others that might need it.  Also, TACTIC runs on top of CherryPy, so you can run it without Apache (this is how Team does it)

-----------

Initialize postgresql

# yum install postgresql-server
# su postgres
# initdb /var/lib/pgsql/data
# exit

# systemctl start postgresql
# systemctl enable postgresql

Install Git
# yum install git

Check out TACTIC
# mkdir /spt/tactic
# su tactic
# cd /spt/tactic
# git clone https://github.com/Southpaw-TACTIC/TACTIC.git
# cd TACTIC
# git checkout 4.1

Prepare python
# su
# yum install python-crypto
# yum install python-lxml
# yum install python-pillow
# yum install python-psycopg2

Install TACTIC
# su
# cd /home/tactic/TACTIC/src/install
# python install.py
Enter:
base_path: /home/tactic
user: tactic

# cd /home/tactic
# chown -R tactic.tactic /home/tactic
# rm tactic
# ln -s TACTIC tactic
# rm -fr tactic_src_4.1.0.v03

# cd tactic/src/bin
# python startup_dev.py

Prepare apache
# su
# cd /home/tactic/tactic/src/install/apache
# cp tactic.conf /etc/httpd/conf.d/
# vi /etc/httpd/conf.d/tactic.conf

Change all instances of “apache” to “tactic”
Ucomment line: “Require all granted”

# systemctl start httpd
# systemctl enable httpd

abdelrahman

Thanks, remko. This is what I suspected, but I just wanted to make sure.

I didn't know that I can run tactic without apache. From your explanation, I understand that apache still has to be installed, right?

I managed to get the full version working on CentOS yesterday, although it had no icons at all. I tried doing it on Linux Mint, but it didn't work, because of an issue with apache. The moment I copy 'tactic.conf' to /etc/apache2/conf-enabled (Mint's equivalent to /etc/httpd/conf.d), apache stops working entirely.

I will see what I can do with it today. Thank you very much for your help.

abdelrahman

Ok. Now I managed to get it installed on both CentOS and Linux Mint, and it works well, and the icons appear correctly. However, I have encountered a weird problem. When ever I try checking-in any file, it doesn't work. It says that file doesn't exist and lists a directory path

<TACTIC installation directory>/tactic_temp/upload/<directory with random long name>/"the name of the file I am trying to check in"

Any idea why is it doing that??