[SOLVED] Moving VM Data Fail

4 posts / 0 new
Last post
Nelli
[SOLVED] Moving VM Data Fail

Hello,
I am currently trying to change my Tactic 4.0.0.rc02 to the latest Tactic 4.3.b01. I use the VMware player to rum my tactic. I followed the instruction in the Tactic docs on 'Moving VM Data'. I have successfully copied the 'assets' folder & tactic_database.sql to the new tactic home/apache folder. (I do not however have the 'Projects' folder as stated in the instructions). 
After copying, I proceeded in doing the dropdb -U postgres sthpw. No errors yet so far. Then I proceeded in typing psql -U postgres < tactic_database.sql, when I typed this and entered, the command lines appeared. But the said that my projects didn't exist. But it kept going until it finished configuring what it needed to.
Thinking that it suceeded, I went to the ip address of the new tactic on Chrome browser, everything appeared fine, I logged in as usual and all my projects are listed in the project view page. But when I click on one of the project, it gave me an error stating the projet does not exist.
So I'm assuming that  Tactic copied only the names of my projects but not the database. Can someone help please?

equinoxin

1. im guessing, but not sure, did you stop you postgres service?
2. not sure if dropdb is neccessary when doing a database restore.
 
 

Nelli

Thank you! I stopped the postgres service while upgrading and it worked!

rajavinoth

how to upgrade while postgresql sevice is stopped.I'm getting the error [ psql: FATAL:  the database system is shutting down] . Help please?