installation error: (sudo python install.py) [SOLVED]

3 posts / 0 new
Last post
kaspar128
kaspar128's picture
installation error: (sudo python install.py) [SOLVED]

Hello Tactic-friends,
 
I am trying to install latest TACTIC-4.4.0.v02 enterprise on a debian-system with Postgresql 9.4
I got till running the installscript: install.py, but now I'm stuck with the following error:
...

Copying files to the install directory... It may take several minutes.

Creating a symlink at [/home/apache/tactic]...

Verifying Python modules are properly installed...

Creating TACTIC temp directories:  /home/apache/tactic_temp
Changing directory ownership of temp and data directories
Creating database 'sthpw' ...

no output, assumed success
Importing sql to database [sthpw]...
   using path [/home/apache/tactic/src/pyasm/search/upgrade/postgresql/bootstrap_schema.sql]
Importing sql to database [sthpw]...
   using path [/home/apache/tactic/src/pyasm/search/upgrade/postgresql/config_schema.sql]
Importing sql to database [sthpw]...
   using path [/home/apache/tactic/src/pyasm/search/upgrade/postgresql/sthpw_schema.sql]
Error with query (Error):  sthpw
      
        --add in admin group
INSERT INTO login_group (login_group, description)
VALUES ('admin', 'Site Administration');

        --add in admin user, default password 'tactic'
INSERT INTO "login" ("login", "password", first_name, last_name)
VALUES ('admin', 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx', 'Admin', '');

        --add the admin user to the admin group
INSERT INTO login_in_group ("login", login_group) VALUES ('admin', 'admin');
        
Traceback (most recent call last):
  File "install.py", line 875, in <module>
    install.execute(install_db=install_db,install_defaults=install_defaults,database_type=database_type, port_num=port_num )
  File "install.py", line 331, in execute
    ''')
  File "install.py", line 30, in run_sql
    db.do_update(sql)
  File "/home/apache/tactic/src/pyasm/search/sql.py", line 817, in do_update
    raise SqlException(e.__str__())
pyasm.search.sql.SqlException: null value in column "upn" violates not-null constraint
DETAIL:  Failing row contains (1, null, admin, xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx, null, null, Admin, , null, null, null, null, null, null, null, null, null, null).

 
I installed all the dependancies, postgreql& apache seem to work, but now I'm stuck woth this error...
Does anyone know how to solve this?
Greetings and thanks in advance!

Diego
Diego's picture

Hi kaspar128,
there is a bug in the setup script for 4.4.0.v02 a patch is already committed for the next version.
For now you can get the patched install script from github:
https://raw.githubusercontent.com/Southpaw-TACTIC/TACTIC/master/src/inst...

Diego

kaspar128
kaspar128's picture

Thanx Diego! That solved my issue!
Had to fix a few other issues due to installing on debian, but now it is working.
If I have time to spare, i'll try to post a how-to install for debian.
 
Kaspar