Alias in Tactic W2008R2

3 posts / 0 new
Last post
fran
Alias in Tactic W2008R2

Hi,
I have installed Tactic-4.5.0.v01 in W2K8R2 with apache 2.4 as a web server. Pythong can access everywhere in our lan by UNC paths. However, python cannot access to any path (locally or network) by an Alias in Tactic. I would like to use Alias to access to some shared resources in our lan. (Alias /P //<server>/shared>)
Apache is working fine with Alias, I have just checked (locally and network) and no problem (\\tactic\<alias_name>). 
However, If I add the line to include tactic_win32.conf in httpd.conf, alias in Apache stop working. I added the same config (httpd.conf in Apache) to configure Alias in tactic_win32.conf  but no luck. I tried all posible combination of slashes, names and so on but nothing happens. Alias only works in Apache when there is no reference to tactic_win32.conf  in httpd.conf
Could anyone help me???
Many thanks in advance.
 

remko

TACTIC conf file takes over all URL at root wit the line:

ProxyPass / balancer://tactic/
 
If you don't want TACTIC to use the root server, then you can comment out this line.
 
Otherwise, for the Aliases that TACTIC itself uses, it has to explicitly make exceptions.
In the tactic conf file, there are a number of lines that put exceptions:
 
ProxyPass /assets !
ProxyPass /context !
Proxypass /doc !
 
And later these are defined as Alias:
 
Alias /context          /home/tactic/tactic/src/context
Alias /assets           /spt/data/sites
Alias /doc/             /home/tactic/tactic/doc/
 
You might want to try adding a "ProxyPass" line for your Alias.
 

 

fran
Hi Remko,
Many thanks for your reply. We tried to map the mounted drive as a folder on root, but we still can't access the file properly then.
 
We have a disk that is mounted on our computers with a letter. Lets say the mounted disk letter is X and we have a file on X:\path1\path2\file.abc
We want to check-in a version with this file on Tactic, but then we get this error:
xmlrpclib.Fault: <Fault 1: "[Errno 2] No such file or directory: u'X:/path1/path2/file.abc'">
 
By mapping the drive as a folder in root, we could see \X\path1\path2\file.abc but not the path above.
 
For more information, what we are trying to do is this (in python):
server = TacticServerStub()
server.set_project("test")
server.start()
assetType = "test/testasset"
asslist = server.query(assetType)
ass = asslist[0]
tacticSearchKey = server.build_search_key(assetType, ass["code"])
filePath = r"X:\path1\path2\file.abc"
newVersion = server.simple_checkin(tacticSearchKey, "publish", filePath, description="test Checkin", mode="inplace")
 
 
It is important to mention that, the above code works fine if we use the UNC of the shared resource.
 
Is there any way that we can see X: from tactic?